public SecretKeySpec (byte[] key, String algorithm)

Constructs a secret key from the given byte array.

This constructor does not check if the given bytes indeed specify a secret key of the specified algorithm. For example, if the algorithm is DES, this constructor does not check if key is 8 bytes long, and also does not check for weak or semi-weak keys. In order for those checks to be performed, an algorithm-specific key specification class (in this case: DESKeySpec) should be used.

Parameters:
key    the key material of the secret key. The contents of the array are copied to protect against subsequent modification.
algorithm    the name of the secret-key algorithm to be associated with the given key material. See the Java Security Standard Algorithm Names document for information about standard algorithm names.

Exceptions:
IllegalArgumentException    if algorithm is null or key is null or empty.