public String getAlgorithm ()
Implementing: java.security.Key
Returns the name of the algorithm associated with this secret key.
Returns: the secret key algorithm.
public
byte[]
getEncoded ()
Implementing: java.security.Key
Returns the key material of this secret key.
Returns: the key material. Returns a new array
each time this method is called.
public String getFormat ()
Implementing: java.security.Key
Returns the name of the encoding format for this secret key.
Returns: the string "RAW".