Constructor that takes a password, salt, iteration count, and
to-be-derived key length for generating PBEKey of variable-key-size
PBE ciphers. An empty char[] is used if null is specified for
password
.
Note: the password
and salt
are cloned before they are stored in
the new PBEKeySpec
object.
password | the password. | |
salt | the salt. | |
iterationCount | the iteration count. | |
keyLength | the to-be-derived key length. |
NullPointerException | if salt is null. | |
IllegalArgumentException | if salt is empty,
i.e. 0-length, iterationCount or
keyLength is not positive. |
Diagram: Key