public class DHPublicKeySpec
  Comment     Returned-by     Constructor-argument     Method-argument     Field-type     Type-bound     Links  

This class specifies a Diffie-Hellman public key with its associated parameters.

Note that this class does not perform any validation on specified parameters. Thus, the specified values are returned directly even if they are null.

implements KeySpec

See also:
DHPrivateKeySpec

Since:  1.4