public class DHPrivateKeySpec
  Comment     Returned-by     Constructor-argument     Method-argument     Field-type     Type-bound     Links  

This class specifies a Diffie-Hellman private key with its associated parameters.

Note that this class does not perform any validation on specified parameters. Thus, the specified values are returned directly even if they are null.

implements KeySpec

See also:
DHPublicKeySpec

Since:  1.4