public static boolean isParityAdjusted (byte[] key, int offset) throws InvalidKeyException

Checks if the given DES-EDE key, starting at offset inclusive, is parity-adjusted.

Parameters:
key    a byte array which holds the key value
offset    the offset into the byte array

Returns:  true if the given DES-EDE key is parity-adjusted, false otherwise

Exceptions:
NullPointerException    if key is null.
InvalidKeyException    if the given key material, starting at offset inclusive, is shorter than 24 bytes