public DESedeKeySpec (byte[] key, int offset) throws InvalidKeyException

Creates a DESedeKeySpec object using the first 24 bytes in key, beginning at offset inclusive, as the key material for the DES-EDE key.

The bytes that constitute the DES-EDE key are those between key[offset] and key[offset+23] inclusive.

Parameters:
key    the buffer with the DES-EDE key material. The first 24 bytes of the buffer beginning at offset inclusive are copied to protect against subsequent modification.
offset    the offset in key, where the DES-EDE key material starts.

Exceptions:
NullPointerException    if key is null.
InvalidKeyException    if the given key material, starting at offset inclusive, is shorter than 24 bytes