Creates a DESedeKeySpec object using the first 24 bytes in
key
as the key material for the DES-EDE key.
The bytes that constitute the DES-EDE key are those between
key[0]
and key[23]
inclusive
key | the buffer with the DES-EDE key material. The first 24 bytes of the buffer are copied to protect against subsequent modification. |
NullPointerException | if key is null. | |
InvalidKeyException | if the given key material is shorter than 24 bytes. |
Diagram: Key