Creates a DESKeySpec object using the first 8 bytes in
key
, beginning at offset
inclusive,
as the key material for the DES key.
The bytes that constitute the DES key are those between
key[offset]
and key[offset+7]
inclusive.
key | the buffer with the DES key material. The first 8 bytes
of the buffer beginning at offset inclusive are copied
to protect against subsequent modification. | |
offset | the offset in key , where the DES key
material starts. |
NullPointerException | if the given key material is
null | |
InvalidKeyException | if the given key material, starting at
offset inclusive, is shorter than 8 bytes. |
Diagram: Key