public DESKeySpec (byte[] key) throws InvalidKeyException

Creates a DESKeySpec object using the first 8 bytes in key as the key material for the DES key.

The bytes that constitute the DES key are those between key[0] and key[7] inclusive.

Parameters:
key    the buffer with the DES key material. The first 8 bytes of the buffer are copied to protect against subsequent modification.

Exceptions:
NullPointerException    if the given key material is null
InvalidKeyException    if the given key material is shorter than 8 bytes.